Yashica TL Electro X repairs

The Yashica TL Electro X was one of the first 35mm film SLR cameras to feature electronic display of exposure information in the viewfinder. It was first produced in 1968 when the majority of cameras used mechanical meter needles to display exposure  and so it represented a first step on the way to today’s electronic cameras.

These pictures can be viewed in full size here.

I found an example of this camera on eBay being sold as non-working but in very good cosmetic condition, and since I already had two poor quality copies which I’d either been given or were included in other sales, I thought I should be able to use parts from all three to make a decent copy. With that thought in mind, I bought this unit for £10 including postage.

When the camera turned up a few days later I found the seller’s pictures of it were accurate and it was in very good cosmetic condition. The only mark is a small indentation in the top of the prism bulge – unfortunate but not catastrophic. There was even the original plastic base protector still in place, so there aren’t even the customary scratch marks round the tripod bush!

The fault the seller referred to was that as the film advance was wound the shutter released during the advance lever return. This turned out to be easy to fix. I removed the bottom plate and discovered that the lever which the shutter release pushes (via a linkage) was frozen in the ‘release’ position. Just actuating it a few times with a pair of tweezers and applying a tiny drop of watch oil released it and the shutter started working properly.

Once the shutter was properly working I found one other fault with the camera. When the metering button was pressed only the OVER exposure LED lit up, irrespective of the position of the aperture or shutter settings. After a bit of google research I found a copy of the service manual for the camera here, and found that the possible causes of this are:

  • The shutter speed / ISO control
  • The light sensors themselves
  • The amplifier board fitted in the base of the camera.

Since I had the other donor cameras I decided to try the board in the bottom of the camera first since this was the easiest thing to try. First, I fitted batteries to the donor camera and confirmed that both exposure LEDs worked on that camera, and then I swapped the board. This was a relatively easy operation because it just involved making a note of the colour of the leads fitted and then unsoldering them and reconnecting the new board.

Unfortunately, although it was an easy operation, it didn’t fix the camera. So the next thing was to get the top off both the good and the donor camera, and see how easy it would be to replace either the shutter speed / ISO control or the light sensors which are fitted either side of the viewfinder.

Removing the top of the camera was a relatively easy operation. There are 5 screws which hold it in place and then the rewind crank needs to be unscrewed in the usual fashion (hold the prongs inside the camera with a screwdriver shaft and unscrew the crank). The only other bits which need removing are the film advance, which is unscrewed with a lens spanner, and the shutter speed dial. This seemed to be held on with hidden screws which I discovered requires prising off the speed label on the top to reveal a single screw in the centre. Once that is out the shutter speed dial pulls off and the camera top can be removed. You need to be careful with it because the flash sync leads remain soldered to the sockets in the top cover.

Once I had the top off the camera I found the easiest part to replace was the shutter speed switch because it was just held in with two screws and a few soldered connections. That was quite easy to swap with a donor camera except some of the connections need to be soldered prior to fixing the switch in place – it’s one of those jobs where an extra pair of hands would be useful!

Unfortunately, changing the shutter speed switch didn’t solve my problem and I had to also replace the light sensors which are fitted in a plastic assembly around the eyepiece. Again this was easy enough, but involved removing a lot of wires in the process – I’ve included pictures above which show the colours for anyone who needs to carry out a similar job. If you do need to do this look carefully at the wires before you remove them – there are black wires which go to the actual light sensors and these don’t need to be unsoldered. The good thing about changing the sensors is that with the wires removed, the whole assembly can be replaced and fixed in the camera before re-making the solder joints.

Fortunately, once the sensors were changed and the camera re-assembled, the exposure system in my camera is working properly and it is ready for a proper test and review.

Advertisements

3 thoughts on “Yashica TL Electro X repairs

  1. Hi simon, thanks for sharing that information . I would like to clean the viewer of my TLX and I needed this info to remove the top of the camera …what I can´t do is remove the speed label from the speed dial !!! How you did that ?? is there a special trick ??? thanks Andre

    • Hi Andre – it is stuck on with glue. Because I had more than one camera I could experiment a bit and I found I could prise it off with a sharp blade carefully inserted at the edge. I guess how easy it is to remove depends how strong the glue is !

Leave a Reply